Piranhas Forum banner
1 - 14 of 14 Posts

·
Piraya & Pitbulls
Joined
·
618 Posts
Discussion Starter · #1 ·
Well i lost my 13"er thursday which was 12 3/4" and today i lost what i thought was 11" but ended up being 12 1/4" piraya.Dont no what went wrong but my big guys are dead.The other 3 littler ones are doing fine and eating but my other 11" (which must be 12" bc he was the same size as todays death)is expected to die soon.Getting rid of the other ones and starting fresh.Everything dried out and recycle the tank.Why do u think they stopped eating?I cant seam to come up with anything.If it was interal how do they get it when they have been in my poscession for awhile.Well the 13" for about 3 months and they 11"er for alittle over a month or so.
 

·
Piraya & Pitbulls
Joined
·
618 Posts
Discussion Starter · #4 ·
Its crazy- i have 2- ac 110s and 2 404s and 1 xp4 for filtration.Powerhead and 2 300 watt heaters.Also two digital therometers.Everything was as best as i could keep it.
Thanks Ak
 

·
Registered
Joined
·
750 Posts
Logic would tell us the two deaths coinciding within such a small time period should be impossible; they both died of the same thing, I guarantee it. I'm sorry to hear of your loss, I would fell jsut as bad if I lost my big red belly.
 

·
Registered
Joined
·
1,968 Posts
Sorry bout your loss....How often do you do water changes? What are your params? Do you freeze the tilapia before you feed it? Have you recently or ever treated for internal parasites? Have they been acting strange lately? Maybe bit into a heater wire or something causing an electrical current in the tank which you haven't noticed? I would for sure try to sort this out before you purchase new fish.Good Luck.
 

·
Piraya & Pitbulls
Joined
·
618 Posts
Discussion Starter · #11 ·
Sorry bout your loss....How often do you do water changes? What are your params? Do you freeze the tilapia before you feed it? Have you recently or ever treated for internal parasites? Have they been acting strange lately? Maybe bit into a heater wire or something causing an electrical current in the tank which you haven't noticed? I would for sure try to sort this out before you purchase new fish.Good Luck.
Thanks zippa.Water changes 2-3 times aweek/water was all zero except 5 ppm nitrate and yes the fish was frozen after bought.Never treated them for nothing bc i thought they where adjusting to new tank.I have two new heaters i just ordered but i will check everything to the T before i start again.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top