Piranhas Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
272 Posts
so i turned onmy tank light this morning to find the water cloudy, knowing it was a bacteria bloom. I just did a water change 2 days ago, so i didnt think my water would be that dirty. Well i added ammo lock, then i did a water change, should have done it the other way around but o well, Any how i got out some of the shrimp particles i missed. I cant find my water tester right now, is there any thing else i should be doing?

I just recently started puttin my flurocent light directly ontop of the tank, would this have any affect?

Im leaving in 2 days,so i need the tank to be in good shape before i take off.
 

·
Registered
Joined
·
272 Posts
Discussion Starter · #4 ·
no , no green, definitly just cloudy, its so wierd this tank has been cycled for at least 3 months, I vacumed on monday, and again today, there is very little particles in the tank. I also cleaned the filter tubes, should I change the filters them selves? I did that probally a month ago maybe 1.5 months ago. I have 2 whipser 60s and only one fish in the tank, its a 75 gal. so they shouldnt be that dirty.
 

·
Registered
Joined
·
2,279 Posts
no , no green, definitly just cloudy, its so wierd this tank has been cycled for at least 3 months, I vacumed on monday, and again today, there is very little particles in the tank. I also cleaned the filter tubes, should I change the filters them selves? I did that probally a month ago maybe 1.5 months ago. I have 2 whipser 60s and only one fish in the tank, its a 75 gal. so they shouldnt be that dirty.
You might need a canister for the 75 gal also. Could be in your decoration driftwood, rocks, plants, etc. Do a big water change and call it a day.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top